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Learning Objectives
g i
Understand the difference between relative, absolute and mixed references.
Understand and apply data sorting.

Understand and apply data filtering.

Understand and apply conditional formatting.

Understand and apply charts creation and modification.
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Cell References - Relative Reference
/' —

s

By default, Excel uses relative reference. See the formula in cell D2 below. Cell D2
references (points to) cell B2 and cell C2. Both references are relative.

COUN... = K v | =B2*C2
A B C D E F G H I
1 Product |Quantity |Price |Amnunt
2 |bread 2 1.5|=B2*C2
3 |butter 1 1.2
4 cheese 3 2
5 ham 3 1.8

Select cell D2, click on the lower right corner of cell D2 and drag it down to cell D5.

COUNM... - K " [ | =B5*C5
A B C D E F G H 1
1 Product |I1uantit-,r|PricE |Amnunt
2 bread 2 1.5 3
3 butter 1 1.2 1.2
4 cheese 3 2 ]
5 |ham 3 1.8| =B5°C5
6

Cell D3 references are cell B3 and cell C3.
Cell D4 references are cell B4 and cell C4.
Cell D5 references are cell B5 and cell C5.
In other words: each cell references are its two neighbors on the left.



Cell References - Absolute Reference

/

See the formula in cell E3 below. Now drag to the other cells.

IF - X & f| =B3*H3

A B C D E F G H |
1
2 Length {cm) [Width {cm) Length {inch) |Width {inch) Conversion rate
3 1 10 |:BS*H3 ! 0.3937008
4 5 10
5 4 8
7] 2 10
7
8
9

E3 - Jx | =B3*H3

A B C D E F G H |
1
2 Length {cm) |Width {cm) Length (inch) |Width {inch) Conversion rate
3 1 10 0.3937008 0 0.3937008
! 5 10 0 0
5 4 8 0 0
5] 2 10 0 0
7 =
8
9

You have got wrong results, why?
Because the reference to cell H3 should be fixed.



Cell References - Absolute Reference

/

Solution;

Create an absolute reference to cell H3, by placing a $ symbol in front of the column
letter and row number of cell H3 ($H$3) in the formula of cell E3.

COUM... - K v x| =B3*SHS3

A B C D E F G H 1

Length (cm) |Width (cm) Length {inch) |Width {inch) Conversion rate
10 |:BB*5H53 | [ 0.3937008
10

(= I B =S Y TR Y O T =

10

Now you can quickly drag this formula to the other cells.

COUN... v~ K « fc| =C6*SHS3
A B C D E F G H 1
1
2 Length {cm) |Width {cm) Length (inch) |Width {inch) Conversion rate
3 1 10 0.3937008 3.937003 [ 0.39370038
4 5 10 1.968504 3.937008
3 4 8 1.5748032 3.1496064
6 JE 0.7874016|=C6*5H53__ |

=

The reference to the cell H3 is fixed (when we drag the formula down and across). As
a result, the correct lengths and widths in inches are calculated.



Cell References - Mixed Reference

S
Sometimes we need a combination of relative and absolute references (mixed reference).
See the formula in cell F2 below,/COUN... ~ (" % « /| =B2°(1-86)
A B C D E F €] H
_ 1 Product |Price Prices / Month |Jan Feb har
We want to copy this formula 5 [jeans 80 Jeans -82+(1-86) |
to the other cells quickly. Drag 2 sh: 30 Shirts |
cell F2 across one cell, and s Month lan  Feb  Mar
look at the formula in cell G2. & Reduction| 20%] 0%  s0%
You got an incorrect result. COUN... - (& X & K| -C2*(1-C6)
A B C D E F G H
Whyr) 1 Product |Price Prices [/ Month |Jan Feb Mar
Because the reference to the 2 [Jeans 3] ] Jeans 64]=c2%(1-C5) |
price should be a fixed reference Shirts 30 Shirts
to column B. 5 Month |lan  Feb  Mar
6 |Reduction 20% A40% 80%
-

Solution: place a $ symbol in front of the column letter of cell B2 ($B2) in the formula of cell
F2.

In a similar way, when we drag the cell F2 down, the reference to the reduction should be

a fixed reference to row 6.

Solution: place a $ symbol in front of the row number of cell B6 (B$6) in the formula of cell F2.



Cell References - Mixed Reference
_—

Result: COUN... ~ K J| =5B2*(1-B56)
A B C D E F G H
1 Product |Price Prices / Month |Jan Feb Mar
2 |leans 80 leans =5B2*(1-B56)
3 (Shirts 30 Shirts T
4
5 Month Jan Feb Mar
6 |Reduction 20% 40% 80%
7
a8

Now we can quickly drag this formula to the other cells.

COUN... - X v Jf | =5B3*(1-D5S6)

A B C D E F €] H
Product |Price Prices f Month |Jan Feb Mar
Jeans a0 Jeans 64 45 16
Shirts Shirts 24 1g] =$83%(1-D36)

Month Jan Feb Mar
Reduction 20% 40% 20%

CO =~ @ L WM =

The references to column B and row 6 are fixed.
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You can sort your Excel data on one column or multiple columns.

You can sort in ascending or descending order.
One Column Sorting:

1. Click any cell in the column
you want to sort.

& Bov 2 To sort in ascending order,
C D -
: Salas JComisly (uaites on the Data tab, click AZ.
2 ! $4,865.00 USA Qtr4d
3 Brown $3,255.00 USA Qtr2
4 Johnson  $14,808.00 USA Qtrd
5 Johnson $9,339.00 UK Qtr2 Formulas Data Revie View Developer
6 Jones 51,39000 USA Qtr3 .__li;]l.’_unnectinns JN
— ! ¥ (alz

7 Jones $9,213.00 USA  Qtra 2 AN A
8 Jones $7,433.00 UK Qtr1l Riﬁejh - Al L \':?Aduanced
9 Smith 516,753_00 UK Qtr3 Connections Sort & Filter
10 Smith $18,919.00 USA Qtr3
11 Smith $9,698.00 USA Qtrl
12 Williams  $10,644.00 UK Qtr 2 .
13 Williams  $12,438.00 UK atr1 Be careful, don't select the
14 williams  $14,867.00usa a3 entire column or the cells that
15 Williams $19,302.00 UK Qtr4

are inside it.

Data Analysis - Sorting Data

Result

A7 - F | Brow
A B C D

1 Last Mame Sales Country Quarter
2 |Brc|wn | sa865.00usa  atra
Brown 53,255.00 USA Qtr2
4 Johnson  514,808.00 USA Qtr 4
5 |Johnsaon 59,339.00 UK Qtr2
& lones 51,390.00 USA Qtr 3
Jones 59,213.00 USA Qtrd
& lones 57,433.00 UK Qtrl
8 |Smith 516,753.00 UK Qtr 3
10 |Smith 518,919.00 UsSA Qtr 3
11 |Smith 59,698.00 USA Qtrl
12 williams  510,644.00 UK Qtr 2
13 Williams  512,438.00 UK Qtrl
14 williams  514,867.00 USA Qtr 3
15 Williams  519,302.00 UK Qtrd



Data Anal

~ Multiple Column Sorting:
1. Onthe Data tab, click Sort. 2. Select Last Name from the 'Sort by"

Formulas Data Review View Developer drop_down IISt
“n || Connections 4 | BT .
5] zl A2 L? &
g 5 HH 3. Click on Add Level.
Refresh Zl Sort Filter
Allr = & _?!':,?Aduanced
[ ] 1 2
Connections Sort & Fitter 4. Select Sales from the "Then by" drop-down list.
Sort \ B ;
| add Level || X Delete Level || 23 Copy L |]| [7] My data has head S. CIICkOK
4] Add Level Delete Level =3 Copy Leve Options. .. v data has headers R I
Column Sort On Crder esu t
Sort by lz‘ Values |Z| AtoZ |Z| A2 - fe | Brown
sal
o A ] e c [ o [
Quarter 1 Last Name Sales Country Quarter
2 |Brc|wn _I 53,255.00 USA Qtr2
3 Brown 54,865.00 USA Qtr4
4 Johnson 59,339.00 UK Qtr 2
OK ] ’ Cancel ]
5 |lohnson  514,808.00 USA Qtr4
\y & Jones 51,390.00 USA Qtr3
Sort =R 7 Jones 57,433.00 UK Qtri
5 & lones 59,213.00 USA Qtr4a
“’gladd Level X Delete Level =2 Copy Level COptions. .. My data has headers
H H ”E] - 9 Smith 59,698.00 USA Qirl
Colurn ==itn Orcer 10 Smith $16,753.00 UK Qtr3
Sortby  |Last Mame lz‘ Values El AtoZ |Z| 11 |smith 518r519-00 USA Qtr 3
Then by E Values E‘ AtoZ E ' .
Last Name é 12 'Williams  510,644.00 UK Qir 2
%‘g‘fﬁw s 13 williams  5$12,438.00 UK Qtri
Quarter 14 williams  $14,867.00 USA Qtr 3
15 |Williams  519,302.00 UK Qird
16
CK ] ’ Cancel
17




- _ ] - /
it Data Analysis - Datakiltering
Filter your Excel data if you only want to display records that meet certain criteria.
Filtering:

1. Click any cell inside a data set.
2. On the Data tab, click Filter.

Formulas Data Review View Developer
) Connections e {
@ ‘J 24 Ei LF . A3 - J= | Johnson
Refresh ) il Sort Filter 7
All - U pdvanced A B C D E
Connections Sort & Flﬂ\\ﬁer 1 Last Nan * | Sales * | Count * | Quarg ~
2 Smith 516,753.00 UK Qtr 3
4 3 |lohnson I$14,EDE.DD UsA Qtr 4
Arrows appear in the column 4 Williams | $10,644.00 UK Q2
headers 5 Jones 51,390.00 USA Qtr 3
& Brown 54,865.00 UsSA Qtr4
7 Williams  $12,438.00 UK Qtrl
3. Click the arrow next to Country. g Johnson  $9,339.00 UK Qtr2
9 |Smith 518,919.00 USA Qtr 3
10 [Jones 59,213.00 USA Ctrd
11 lones 57,433.00 UK Qtr 1
12 |Brown 53,255.00 USA Qtr 2
13 |Williams  514,867.00 USA Qtr 3
14 'Williams  519,302.00 UK Ctrd
15 |Smith 59,698.00 USA Qtrl
16

=
I.\_‘J



~ Data Analy
/

~

sis - Data Filtering

4. Click on Select All to clear 5. Click the check box next to USA. 6. Click OK.

all the check boxes.
Al | B c D Al sotatpz
1 Last Ndn ~ Sales * | Count ~ Quart = -
Ta Q 2l sotztpa
1%} zortRtoz
fil sort Fto A Sort byColor 4
Sort gy Color k { v
A3 w J= | Johnson
Text Fil§ers 4 A BE C D
H - - ,.T -
Text Hilters ¢ Search I 1 |Last Nan = Sales Count-T Quart
i 3 |Jc|hr15c|n |$14,EDE.DD LSA Qtrd
Seardh Pl | [~ [m] 5elect All) 1
M - = 5 |lones 51,390.00 USA Qtr 3
..... O 5:51“ 6 Brown $4,865.00 USA Qtr4
IZl ot 2 B 9 |Smith $18,919.00 USA Qtr 3
|:| Qir 3 10 |Jones 59,213.00 USA Qtr4
~L1Qr 4 12 Brown $3,255.00 USA Qtr 2
13 |Williams  514,867.00 USA Qtr 3
15 |Smith 59,698.00 USA Ctrl
16
17

Ok 0K l’ Cancel




Data Analysis - Conditional Formatting

——

Conditional formatting in Excel enables you to highlight cells with a certain

color, depending on the cell's value.

Highlight Cells:
1. Select the range A1:A10.
Al ~ fe | 14
B B C
1 14
2 il
3 39
4 43
5 2
o 95
7 5
8 11
9 B6
10 5?.
11
12

2. On the Home tab, click Conditional Formatting,
Highlight Cells Rules, Greater Than.

E:I"éjlj _L_‘ﬁl Mormal

Bad Good MNeu

Conditional | Format |

| | Explanatory... [Inpt

Formatting =|as Table =

i | Highlight Cells Rules *

5
i:] | Top/Bottom Rules
i
Data Bars

Color Scales

Icon Sets

b B

Mew Rule...

Clear Rules

= 'L"_ [

Manage Rules...

= | Greater Than...

3

= | Less Than...

=
ﬂ Between...

—'| Equal To...
—'| Text that Contains...

—% A Date Occurring...

=d| Duplicate Values...

More Rules...



Dat
p

/

a Analysis - Conditional Formatting

3. Enter the value 80, select a formatting style, and then
click OK.

e

]

Gleater Than
rmat cells that are GREATER THAM:

o el

B8] with | Light Red Fill with Dark Red Text [

[ QK ]| Cancel |

l Result :Excel highlights the cells that are greater than 80

E14 ~ Je

A B C
1 14
2 6
3 39
4 43
5 2
6 g5
7 5
8 11
9 86
10 57
11

=
P2



| Data Analysis - Charts
/

A simple chart in Excel can say more than a sheet full of numbers.
Creatlnq a Chart Home Insert Page Layout Farm

= - . ElE _}Shapes'
JJ‘ H |04l BE T2 smartart

1- SeIeCt the range A1D7 FivotTable Table Picture  Clip !

- Art @t Screenshot -
Tables INustrations
Al - £ | Month
A | B | D

Month  Bears Dolphins Whales

Jan B 150 80/
Feb 34 77 34
Mar 93 32 100
Apr 116 11 76
May 137 6 93
Jun 184 1 72




A simple chart in Excel can say more than a sheet full of numbers.
Creatlnq a Chart “ Home Insert Page Layout Formulas Data Review View Developer

7 E3 b B2 e @ T el 0D

; EEl
1' SeIECt the range A1D7 PivotTable Table Picture Clip %Smart&rt Column| Line Pie Bar Area Scatter Other

- Art @t Screenshot - - - - - - *  (Charts~
2 On the Insert tab In Tables INustrations 2-D Line
: ’ | AL~ £ | Month P
the Charts group, choose | T | < _ - l‘_, <A |l .
Llne and Select Llne Wlth 1 |Month  Bears Dolphins Whales
: 2 [1an 8 150 80 e | A
Markers. 3 |Feb 54 77 54 ¥ [y gl .
_4 |Mar 93 32 100 3-D L Line with Markers
5 |Apr 116 11 76 , _
— . Display trend over time [dates,
_ 6 |May 137 6 93 vy years) or ordered categories.
Ll L L B Useful when there are only a few
2 data points.
9
10
200

ReSUIt: 180 /0—

‘
=N —
100 \ '/ =—¥=—Bears
w0 L k / - == Dolphins
o f/’/ Whales
" 7\
wl S A

/ T T




Changing the Chart Type:

1. Select the chart (just click on it).

2. On the Insert tab, in the Charts group, choose Column, and select Clustered Column.

-
E :l . ElE @Shapes

PwotTabIe Table

Tables

Art |‘;_—-)+5creenshot

Farmulas Data Review

Developer I

ﬁmoshLo

| Chart3 ~ (.

A

Month [l

Dolphins Whales ]

(RN T STV S

| | |
ERELRERBRELE|

.Jan
Feb
Mar
Apr
May
Jun

2-D Column

s [m] 18]

Column L|ne Pie Bar Area Scatter Other

~ Charts =

3-p ¢ Clustered Column

Compare values across categories
by using vertical rectangles.

Use it when the order of categories

is not important or for displaying
item counts such as a histogram.

mmn

dem

Pyramid

i) |aA] A

illi 20 chart Types...

200
180
160

140
120
100

3

20 A

lan




Switching Row/Column:

1. Select the chart, The Chart Tools contextual tab appears.
2. Click on the Design tab, then click Switch Row/Column.

| (=, R N charts [Compatibility Mode] - Microsoft Excel Chart Tools

Home Insert Page Layout Formulas Data Review View Developer | Design Layout Fo

il & E
Change Save As Switch Select Quick II II

Chart Type Template | Row/Column| Data Layout =
Type Data Chart L... Chart Styles

d |

v

Result:

Bears Dolphins Whales

M lan

EFeb
B Mar
W Apr
m May

M lun




Adding Chart Title:
1. Select the chart, The Chart Tools contextual tab appears.

2. On the Layout tab, click Chart Title then Above Chart.

cmpatibility Mode] - Microsoft Excel

armulas Data Review View Developer

whart [ools ‘

Design | Layout Format

] || | s

= =il 2
|| o] ] (] ) ()
Chart | Axis Legend Data Data Axes  Gridlines
Title = | Titles = = Labels = Table = = =

Mone Axes

Plot
Area =

Chart Chart 3-D
Wall = Floor = Rotatior

Background

Do not display a chart Title

— Centered Overlay Title H |
|I_ Owerlay centered Title on
—— cthart without resizing chart
— Above Chart

Display Title at top of chart
area and resize chart I},

e

Maore Title Options...

3. Enter a title. For example, Population.

Result:

Population
200
180
160
M lzan
140
120 4 M Feb
100 4 = Mar
B0 W Apr
60 - o May
a0
W lun
20
o
Bears Dolphins Whales




e

Changing the Legend Position:
1. Select the chart. The Chart Tools contextual tab appears.

2. On the Layout tab, click Legend then Show Legend at Bottom.

ompatibility Mode] - Microsoft Excel Chart Tools

armulas Data Review Wiew Developer Design | Layout Format |

= -
U{rlina E W il —I —I —I —I |
|ﬂ—‘ | —'-—I |ﬂj| ,|_|'|I'|—| o [ (G| | |dod )
Chart  Axis |Legend| Data Data Axes  Gridlines Plot Chart Chart 3-b ReSUIt.
Title = Titles = 2 Labels = Table = = = Area~ Wall~ Floor~ Rotatio
= None Background
s  Turn off Legend .
= Population
E Show Legend at Right 1 K L 200
ﬂJ Show Legend and align
right
] Show Legend at Top 150
il Show Legend and top
align
Show Legend at Left é 100
Jﬂ Show Legend and align
left
] Show Legend at Bottom 50 A
'—E., Show Legend and align
bottom
Overlay Legend at Right 0 .
,|LJ Show Legend at right of Bears Dolphins Whales
the chart without resizing
Overlay Legend at Left Mlan MFeb WMar BApr EMay Blun
Elm | showLegend at left of
the chart without resizing
More Legend Options...




——

Analysis = Charts

Data Labels:
Use them to get the reader’s attention on a single data series or data point.

Steps for adding data labels:

ompatibility Mode] - Microsoft Excel ChartTools

armulas Data Review View Developer Design | Layout | Format

1. Select the chart. The Chart Tools & 2] o i) [B] | ] [ | (@ 6 =
Contextual tab appears- Chart Axis Llegend| Data | Data Axves Gridvlines Plot Chart Chart  3-D Trenvdline Lines

Title = Titles = < Labels =| Table = Area~ Wall~ Floor - Rotation
Labels - None Background An

2. Click an orange bar to select the Jun data Tsnestispsysosss (LA Tamaoss o
series. Click again on an orange bar to select =~ ] somosissispern 0 T

centered on the data pointis)
. = Inside End
a SI ng I e data po I nt. J Display Data Labels and position
inside the end of data point(s)
Inside Base
J Display Data Labels and position

3. On the Layout tab, click Data Labels, then insid the base o da poin()

- Outside End
= [ ] | Display Data Labels and position N
Select OUtSlde End . outside the end of data[}oint[s]
Maore Data Label Options...
200
150
Population 100 4
200
50 4
150
o -
100 4 Bears Dolphins Whales
50 - B lan EFeb B Mar BApr EMay Hlun
L <
o -
Bears Dolphins Whales
HJan EFeb EMar EApr EMay Hlun




Thank you ..

Good Luck and Success

Asst. Lecturer Sajjad Ibrahim
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