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Cell Basics and Formatting

Whenever you work with Excel, you'll enter information, or content, into cells. Cells are the
basic building blocks of a worksheet. You'll need to learn the basics of cells and cell content

to calculate, analyse, and organize data in Excel.

2.1 Understanding Cells

Every worksheet 1s made up of thousands of rectangles. which are called cells. A cell 1s the
mtersection of a row and a column. Columns are identified by letters (A, B, C), while rows
are 1dentified by numbers (1, 2, 3).
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Each cell has its own name, or cell address, based on its column and row. In this example,
the selected cell intersects column C and row 5, so the cell address 1s C5. The cell address
will also appear in the Name box. Note that a cell's column and row headings are

highlighted when the cell 1s selected.
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You can also select multiple cells at the same time. A group of cells 1s known as a cell
range. Rather than a single cell address, you will refer to a cell range using the cell
addresses of the first and last cells in the cell range. separated by a colon. For example, a
cell range that included cells A1, A2, A3, A4, and AS would be written as A1:AS.

In the images below, two different cell ranges are selected:

Cell range A1:B8 Cell range A1:A8

Al v Al v

D 0O =1 oh U B W R
WO =~ e u W R

o To select a cell range
Sometimes you may want to select a larger group of cells, or a cell range.

1- Click, hold, and drag the mouse until all of the adjoining cells you wish to select are
highlighted.

2- Release the mouse to select the desired cell range. The cells will remain selected until
you click another cell in the worksheet.
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2.2 Cell Content

Any information you enter into a spreadsheet will be stored in a cell. Each cell can contain
several different kinds of content, including text, formatting, formulas, and functions.

e Text

Cells can contain text, such as letters, numbers. and dates.

A B C
1 |Date Sales Percentage of Total
2 |5/6/2013 65 0.71
3 5/7/2013 78 0.78
4 |5/8/2013 112 0.86
5 5/9/2013 54 0.28
6 |5/10/2013 99 0.49
7 |5/11/2013 189 0.65
g8 |5/12/2013 120 0.57
9

¢ Formatting Attributes

Cells can contain formatting attributes that change the way letters, numbers, and dates are
displayed. For example, percentages can appear as 0.15 or 15%. You can even change a
cell's background color.

e Formulas and Functions
Cells can contain formulas and functions that calculate cell values. In our example, SUM

(B4:B7) adds the value of each cell in cell range B4:B7 and displays the total in cell BS.

B8 v j\ =SUM(B4:B7)
A B C D E
3 |Date Students Percentage
4 | 1/2/2015 36 36% 100
5 | 1/3/2015 50 50%
6 | 1/4/2015 14 14%
7 | 1/5/2015 55 55%
8 | 155

- —

Email : alaa.khalid.abdalreda@uomus.edu.ig



mailto:alaa.khalid.abdalreda@uomus.edu.iq

Al-Mustaqgbal University / College of Technical Engineering
Department: Medical Instrumentation Techniques Engineering
Class: Fourth
Subject: Computer Applications / Code: MU0244007
Lecturer: M.Sc. Alaa Khalid& M.sc Ali Kareem
25t term-Lecture No. 2&3/ Cell Basics and Formatting.

e To delete cell content

1- Select the cell with content you wish to delete.
2- Press the Delete or Backspace key on your keyboard. The cell's contents will be

deleted.

e To delete cells

There 1s an important difference between deleting the content of a cell and deleting the cell
itself. If you delete the entire cell, the cells below it will shift up and replace the deleted
cells.

1- Select the cell(s) you wish to delete.
2- Select the Delete command from the Home tab on the Ribbon.
3- The cells below will shift up.

Fepe— ':l'::'r_x El > AutoSum  — A&
= =

== (== -
l:g- =] Fin -
Insert Delete™Format Sort 8
- - - T Clear ~ Filter —

Cells Editing
Delete Cells

Delete cells, rows, coelumns, or
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e To copy and paste cell content

Excel allows vou to copy content that 1s already entered mto your spreadsheet and paste that
content to other cells, which can save you time and effort.

1- Select the cell(s) you wish to copy.
2- Click the Copy command on the Home tab, or press Ctrl+C on your keyboard.

FILE HOPME INSERT PAGE LAYOUT
.
[ Ex Cut Caliibai -1
& Cc -
Paste |%' p% B I U - E
- ~ Format Painter = -
Clipboard M Font

D2 Copy (Ctrl+C) «

Put a copy of the selection on the
Clipboard so you can paste it

. somewhere else.
1 |Fir

Figure 34

3- Select the cell(s) where you wish to paste the content. The copied cells will now have
a dashed box around them.

4- Click the Paste command on the Home tab, or press Ctrl+V on your keyboard.

5- The content will be pasted into the selected cells.

o To access more paste options
You can also access additional paste options, which are especially conwvenient

working with cells that contain formulas or formatting. To access more paste options,
the drop-down arrow on the Paste conmumand.

=H - X =
FILE HOME INSERT PAGE LAYOL
N
J6 Cut Calibri -
Em Copy ~
Paste - ~ B I U - i
- ' Format Painter - i
Paste r= Font
e e = - —
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Keep Scource Formatting (K) ?
FPaste Values
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Other Paste Options
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o To use the fill handle

There may be times when vou need to copy the content of one cell to several other cells in
your worksheet. You could copy and paste the content into each cell, but this method would
be very time consuming. Instead, you can use the fill handle to quickly copy and paste

content to adjacent cells in the same row or column.

1- Select the cell(s) containing the content you wish to use. The fill handle will appear
as a small square in the bottom-right corner of the selected cell(s).
2- Click, hold, and drag the fill handle until all of the cells you wish to fill are selected.

3- Release the mouse to fill the selected cells. A B =
1 Ix x
2 X
3 =)
A B c 4

5

1 |x X 5

2 X ﬁ 7

3 = 8

4 [°]

5 10
11 o
12

[
w

e To continue a series with the fill handle

The fill handle can also be used to continue a series. Whenever the content of a row or
column follows a sequential order, like numbers (1, 2, 3) or days (Monday, Tuesday,
Wednesday), the fill handle can guess what should come next mn the series. In many cases,
you may need to select multiple cells before using the fill handle to help Excel determine
the series order. In our example below, the fill handle is used to extend a series of dates in a

column.

A B C A

Monday Monday
Tuesday Tuesday
Wednesday

1
2
3
- = 4 |Thursday
5
6
7

Friday
Saturday
Sundav

S O B W N

Crinrlav
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2.3 Formatting Cells

All cell content uses the same formatting by default, which can make 1t difficult to read a
workbook with a lot of mformation. Basic formatting can customize the look and feel of
your workbook, allowing you to draw attention to specific sections and making your
content easter to view and understand. You can also apply number formatting to tell Excel
exactly what type of data you’re using in the workbook, such as percentages (%), currency
($). and so on.

Font Formatting

e To change the font

By default, the font of each new workbook 1s set to Calibri. However, Excel provides a
variety of other fonts you can use to customize your cell text. In the example below, we'll
format our title cell to help distinguish it from the rest of the worksheet.

1- Select the cell(s) you wish to modify.

2- Click the drop-down arrow next to the Font command on the Home tab. The Font
drop-down menu will appear.

3- Select the desired font. A live preview of the new font will appear as you hover the
mouse over different options.

Bz - - “. | [N
Galibi ~/11 ~ A" A $ - % +» &
A L BI=od-pA-im-q0ma F
1
2 | list _|
3

Email : alaa.khalid.abdalreda@uomus.edu.ig



mailto:alaa.khalid.abdalreda@uomus.edu.iq

Al-Mustaqgbal University / College of Technical Engineering
Department: Medical Instrumentation Techniques Engineering
Class: Fourth
Subject: Computer Applications / Code: MU0244007
Lecturer: M.Sc. Alaa Khalid& M.sc Ali Kareem
25t term-Lecture No. 2&3/ Cell Basics and Formatting.

The text will change to the selected font.

‘N

%+ TIP: When creating a workbook in the workplace, you'll want to select a font that
1s easy to read. Along with Calibri, standard reading fonts mclude Cambria, Times

New Roman, and Anal.

o To change the font size

1- Select the cell(s) you wish to modify.
2- Click the drop-down arrow next to the Font Size command on the Home tab. The Font

Size drop-down menu will appear.
Select the desired font size. A live preview of the new font size will appear as you hover

the mouse over different options.
The text will change to the selected font size.

I
i

TIP: You can also use the Increase Font Size and Decrease Font Size commands

or enter a custom font size using your keyboard.

FILE HOME INSERT PAC

T Calibri =111 -
—T Exy - B r g - A A
Paste . =
- o » - A -~
Entering a custom Font I [
font size

Increase and
Decrease Font
Size commands
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o To change the font color

1- Select the cell(s) you wish to modify.
2- Click the drop-down arrow next to the Font Color command on the Home tab. The

Color menu will appear.
3- Select the desired font color. A live preview of the new font color will appear as you

hover the mouse over different options.
HOME INSERT PAGE LAYOUT FORM
Calibri |11 -
B I U- A a
. O - A -

Font [l Automnatic

(R

Theme Colors

E— .IIIllllll

Standard Colors

w» More Colors...

-

e To use the Bold, Italic, and Underline commands

1- Select the cell(s) you wish to modify.
2- Click the Bold (B). Italic (/). or Underline (U) command
example. we'll make the selected cells bold.

on the Home tab. In our

J6 Cut Georgia - 118 - A A = =
Em Copy ~ ) -
~ Format Painter BI::\}I u - g - 2 A ===
Clipboard P Font =
Bold (Ctrl+B)
- og
Make your text bold.
A = C
Figure 41

3- The selected style will be applied to the text.

TIP: You can also press Ctrl+B on your keyboard to make selected text bold,
Ctrl+I to apply italics, and Ctrl+U to apply an underline.

Text Alignment

By default, any text entered into your worksheet will be aligned to the bottom-left of a cell.
Any numbers will be aligned to the bottom-right of a cell. Changing the alignment of your
cell content allows you to choose how the content 1s displayed 1n any cell, which can make

vour cell content easier to read.
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e To change horizontal text alignment

1- Select the cell(s) you wish to modity.

2- Select one of the three horizontal alignment commands on the Home tab. In our
example, we'll choose Center Align.

= = = £~ E(_"W'rap Text

= = Merge & Center -~

Alignment =

Center your content.

o To change vertical text alignment

1- Select the cell(s) you wish to modify.

2- Select one of the three vertical alignmment commands on the Home tab. In our example,
we'll choose Middle Align.

= E%E - =¢ Wrap Text
= = = = 3= [E Merge & Center ~
Alignment -
Middle Align

[Log
Align text so that it is centered
between the top and bottom of the
cell.

@

Figure 43

3- The text will realign.

2.4 Cell Borders and Fill Colors

Cell borders and fill colors allow you to create clear and defined boundaries for different
sections of your worksheet.

e To add a border

1- Select the cell(s) you wish to modify.

2- Click the drop-down arrow next to the Borders command on the Home tab. The Borders
drop-down menu will appear.
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5 Top Border

Left Border

Right Border
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3- Select the border style you want to use.
4- The selected border style will appear.

e TIP: You can draw borders and change the line style and color of borders with the
Draw Borders tools at the bottom of the Borders drop-down menu.

Draw Borders
™4 Draw Border
l__',r Drraw Bnrd&r%rid
¢ Erase Border
2 Line Color 4
Line Style r

FH Mere Borders...
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e To add a fill color

1- Select the cell(s) you wish to modify.

2- Click the drop-down arrow next to the Fill Color command on the Home tab. The Fill
Color menu will appear.

3- Select the fill color you want to use. A live preview of the new fill color will appear
as you hover the mouse over different options. In our example, we'll choose Light

Green.
HOME INSERT PAGE LAYOUT

Calibri o Lt =
- B I U~ A A ==
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Theme Colors
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Standard Colors
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No Fill
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vy More Covors:

2.5 Formatting Text and Numbers

Omne of the most powerful tools i Excel 1s the ability to apply specific formatting for text
and numbers. Instead of displaying all cell content in exactly the same way, you can use
formatting to change the appearance of dates, times, decimals, percentages (%), currency

($), and much more.

e To apply number formatting

1- Select the cells(s) you wish to modify.

2- Click the drop-down arrow next to the Number Format command on the Home tab. The
Number Formatting drop-down menu will appear.

3- Select the desired formatting option.

4- The selected cells will change to the new formatting style.
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General is the defauit format for any cell. l

When you enter a number into the cell, ABC
Excel will guess the number formatthatis — > 123
most appropriate.

12

Currency formats numbers as curency _,

' with a currency symbol.

Short Date formats numbers

. as MID/YYYY. "_;

Long Date formats numbers as

Weekday, Month DD, YYYY. "E

-

Percentage formats numbers with
decimal places and the percent sign. "%
%)
Scientific formats numbers 2
' inscientificnotation. > | ()
ABC
You can easily customize any format in

. More Number Formats.
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Gene
No specific format
Number Number formats numbers
fist i with decimal places.
Currency
ist
’ Accounting formats numbers as monetary
Accounting values like the Currency format, but it also
list aligns currency symbols and decimal
places within columns.
Short Date
list
Long Date
hst
Time ~ Time formats numbers as HH/MM/SS
fist ¢ ludmﬂorl’l.
Percentage ‘
hst
Fraction formats numbers as fractions
Fraction ’—‘l separated by the forward slash.
list
Scientific ‘
list
Text formats numbers as text, meaning
Text that what you enter into the cell will
list appear exactly as it was entered.
Figure 47
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Modifying Columns, Rows and Cells

By default, every row and column of a new workbook 1s always set to the same height and
width. Excel allows [you to modify column width and row height in different ways.
including wrapping text and merging cells.

o To modify column width

1- Position the mouse over the column line in the column heading so the white cross
becomes a double arrow.
H18 - I
A B C
First Na Last Name
Amand: Ryan

Tricia Matthews
Josefini Woodard

[ IN¥, I VE I S I

2- Click, hold, and drag the mouse to increase or decrease the column width.
3- Release the mouse. The column width will be changed.

% TIP: If you see pound signs (######) 1n a cell, it means that the column is not
wide enough to display the cell content. Simply increase the column width to
show the cell content.

o To AutoFit column width
The AutoFit feature will allow you to set a column's width to fit its content automatically.
1- Position the mouse over the column line in the column heading so the white cross
becomes a double arrow.
2- Double-click the mouse. The column width will be changed automatically to fit the
content.

% TIP: You can also AutoFit the width for several columns at the same time. Simply
select the columns you would like to AutoFit, then select the AutoFit Column
Width command from the Format drop-down menu on the Home tab. This method
can also be used for Row height.
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3.11Inserting. Deleting. Moving. and Hiding Rows and Columns

After you've been working with a workbook for a while, you may find that you want to
msert new columns or rows, delete certain rows or columns, move them to a different
location in the worksheet, or even hide them.

o To insert rows

1- Select the row heading below where you want the new row to appear.
2- Click the Insert command on the Home tab.

P < E I tv i

Cell Inse Delete Format Sort & Find &
Styles ~ - - - — 7 Filter ~ Select ~
Cells Editing

Insert Cells

Add new cells, rows or columns to
your workbook.

FY¥1: To insert multiple rows or
columns at a time, select multiple
rows or columns in the sheet, and

click Insert.

e Tell me more

3- The new row will appear above the selected row.

e To insert columns

1- Select the column heading to the right of where you want the new column to appear.
2- Click the Insert command on the Home tab.

P & < E Z oy itk

- -

Cell Inse Delete Format = Sort & Find &
Styles ~ - - - = 7 Filter ~ Select~
Cells Editing

Insert Cells

Add new cells, rows or columns to
your workbook.

FYl: To insert multiple rows or
columns at a time, select multiple
rows or columns in the sheet, and

click Insert.

e Tell me more

Email : alaa.khalid.abdalreda@uomus.edu.ig



mailto:alaa.khalid.abdalreda@uomus.edu.iq

Al-Mustaqgbal University / College of Technical Engineering
Department: Medical Instrumentation Techniques Engineering
Class: Fourth
Subject: Computer Applications / Code: MU0244007
Lecturer: M.Sc. Alaa Khalid& M.sc Ali Kareem
25t term-Lecture No. 2&3/ Cell Basics and Formatting.

3- The new column will appear to the left of the selected column.

e TIP: When inserting rows and columns, make sure you select the entire row or
column by chicking the heading. If you select only a cell i the row or column, the
Insert command will only nsert a new cell.
o To delete rows
It's easy to delete any row that you no longer need in your workbook.
1- Select the row(s) you want to delete.
2- Click the Delete command on the Home tab.

Tl R g )

& -
Cell Insert Delete Format Sort & Find &
Styles ~ - - - — 7 Filter - Select ~
Cells Editing

Delete Cells

Delete cells, rows, columns, or
H sheets from your weorkbook.

FYIl: To delete multiple rows or
columns at a time, select multiple

rows or celumns in the sheet, and
click Delete.

Figure 51

3- The selected row(s) will be deleted, and the rows below will shift up.
o To delete columns
1- Select the columns(s) you want to delete.

2- Click the Delete command on the Home tab.

B —

P == B0 Z2v ik

] -
Cell Insert Delete Format Sort 8& Find &
Styles - ~ - - — 7 Filter ~ Select -
Cells Editing

Delete Cells

Delete cells, rows, columns, or
H sheets from your workbook.

F¥1: To delete multiple rows or
columns at a time, select multiple
rows or columns in the sheet, and
click Delete.
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3- The selected columns(s) will be deleted, and the columns to the right will shift left.

% TIP: It's important to understand the difference between deleting a row or column
and sumply clearing 1ts contents. If you want to remove the content of a row or
column without causing others to shift, nght-click a heading, then select Clear
Contents from the drop-down menu.

o To move a row or column
Sometimes you may want to move a column or row to rearrange the content of your
worksheet.
1- Select the desired column heading for the column you wish to move, then click the
Cut command on the Home tab or press Ctrl+X on your keyboard.
2- Select the column heading to the night of where you want to move the column. For
example, 1f you want to move a column between columns B and C, select column C.
3- Click the Insert command on the Home tab, and then select Insert Cut Cells from the
drop-down menu.

L o R e ] A .
4 €0 oX [p 2 AutoSum
» tH == E

o Fill =
Cell Insert Delete Format
Styles - - - v & Clear~
Eﬂ: Insert Cut Cells Editir

YR Insert Sheet Columns
E;l_ Insert Sheet
Figure 53

4- The column will be moved to the selected location, and the columns to the right will

shift right.

% TIP: You can also access the Cut and Insert commands by right-clicking the
mouse and then selecting the desired commands from the drop-down menu.
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o To hide and unhide a row or column
At tumes, you may want to compare certain rows or columns without changing the
organization of your worksheet. Excel allows you to hide rows and columns as needed.
1- Select the column(s) you wish to hide, right-click the mouse, and then select Hide
from the formatting menu.

a6 Cut
E® Copy
-,

™y Paste Options:

— —_—
= —
Frida Paste Special...
X Insert
xX Delete
o Clear Contents

E Format Cells...
Column Width...
Hide

Unhide
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2- The columns will be hidden. The green column line indicates the location of the
hidden columns.

Green
column line

st Name | Friday, March 08, 2013
Heidi

Figure 55

3- To unhide the columns, select the columns to the lett and right of the hidden columns
(in other words, the columns on both sides of the hidden columns).

4- Right-click the mouse, then select Unhide from the formatting menu. The hidden
columns will reappear.

3.2Wrapping text and merging cells

Whenever you have too much cell content to be displayed n a single cell, you may decide
to wrap the text or merge the cell rather than resizing a column. Wrapping the text will
automatically modify a cell's row height, allowing cell contents to be displayed on multiple
lines. Merging allows you to combine a cell with adjacent, empty cells to create one large
cell.

1- Select the cells you wish to wrap.

2- Select the Wrap Text command on the Home tab.
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o To merge cells using the Merge & Center command

1- Select the cell range you want to merge together.
2- Select the Merge & Center command on the Home tab.

E:’ Wrap Text Text " -;L g
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Figure 57

3- The selected cells will be merged, and the text will be centered.

e To access more merge options

Click the drop-down arrow next to the Merge & Center command on the Home tab. The
Merge drop-down menu will appear. From here, you can choose to:

Merge & Center: Merges the selected cells ito one cell and centers the text

Merge Across: Merges the selected cells into larger cells while keeping each row
separate

Merge Cells: Merges the selected cells into one cell, but does not center the text
Unmerge Cells: Unmerges selected cells
Merge & Center ~
=l Merge & Center
Merge Across

Merge Cells %

E 00 [ A

Unmerge Cells
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